nixos/lil-maid/fs.nix
2024-12-17 00:25:43 +03:00

22 lines
459 B
Nix

{
fileSystems = {
"/" =
{ device = "/dev/disk/by-label/nixos";
fsType = "btrfs";
};
"/boot" =
{ device = "/dev/disk/by-label/boot";
fsType = "vfat";
options = [ "fmask=0077" "dmask=0077" ];
};
"/secrets" =
{ device = "/dev/disk/by-label/secrets";
fsType = "btrfs";
options = [ "nofail" ];
};
};
swapDevices =
[ { device = "/dev/disk/by-label/swap"; }
];
}